Project

General

Profile

Very small font on Raspberry Pi

Added by Saxx over 4 years ago

Hi

I'm using the desktop client via VNC on Raspberry Pi and the font is very small. Some places too small to read. Have a look at the attaced screenshot. Other windows opened have a normal, readable, font size both on the menues and on text in general.

Any way to fix this?

/Ronny

desktop.png (119 KB) desktop.png Desktop screenshot
2224

Replies (9)

RE: Very small font on Raspberry Pi - Added by danfos over 4 years ago

Had a look in the sources and see in Main.module:

  ' Set font to default "Sans Serif" with size 9
  Application.Font.Name = "Sans Serif" 
  Application.Font.Size = 9

So what you could try is to change that, recompile and see.

Looking at you screen shot however you seem to have not too much room to increase the size or the Interface menu will not fit anymore although with the latest commits of Wouter moving Plugwise, Omnisol, there is a bit more space.

Another solution would be to run DomotiGa in a client-server setup, but for that you need to have a Linux desktop...

RE: Very small font on Raspberry Pi - Added by Saxx over 4 years ago

Ok. Thanks for the feedback. :)

/Ronny

RE: Very small font on Raspberry Pi - Added by Saxx over 4 years ago

Haven't tried it yet. I'll let you know when I do.

/R

RE: Very small font on Raspberry Pi - Added by Saxx over 4 years ago

There are other implications to the small font problem.

When I try to use the thermosat, when I click a square, the one above or sometimes 3 above is selected. Therefore I'm unable to select wednesday, tru saturday. I have also seen that squares diagonally is selected instead of the ones I click. See attached image.

/Ronny

Schedule.png (10.6 KB) Schedule.png Schedule
2233

RE: Very small font on Raspberry Pi - Added by Saxx over 4 years ago

I finally managed to get around this problem. Instead of using VNC, I use a program called MobaXterm. I connect to the Raspberry Pi using X-11 forwarding and "Remote environment: LXDE desktop". See attached image.

MobaXterm can be downloaded here: [[http://mobaxterm.mobatek.net/]]

MobaXterm settings.png (70.5 KB) MobaXterm settings.png MobaXterm settings
FontOK.png (106 KB) FontOK.png Font OK
2235
2236

RE: Very small font on Raspberry Pi - Added by danfos over 4 years ago

Hi Saxx,

Thanks for coming back on this and glad to hear you can solve this using X11 over SSH, I use the same method to start a graphical editor on my Cubieboard.

How is the performance or the sluggishness of DomotiGa? For me, resizing windows in Gambas was too slow so for that I reverted to RDP.

MobaXterm seems like a nice solution for Windows.

RE: Very small font on Raspberry Pi - Added by Saxx over 4 years ago

Window handling in general is very slow, but hey, it works :)

RE: Very small font on Raspberry Pi - Added by Saxx over 4 years ago

I found a fix for this problem. Add '-dpi 96' to the command line or script you use to start the VNC server.

su pi -c 'vncserver :0 -geometry 1366x768 -depth 16 -dpi 96 -pixelformat rgb565:'

A complete tutorial can be found here: [[http://elinux.org/RPi_VNC_Server]]

    (1-9/9)