Visonic PowerMaster 10

Added by edevag almost 4 years ago


I'm very new to this and I'm trying to connect my Visonic PowerMaster 10 home alarm to a DomotiGa server on a Raspberry Pi (Raspbian). It's connected through the USB program kit cable (Visonic part no. 9-102071) to the USB port on the Raspberry Pi. It's a USB-UART converter.

I've added the Visonic interface and some devices, but it doesn't seem to recognise them.

Any help would be much appreciated.


Replies (13)

RE: Visonic PowerMaster 10 - Added by Alexie almost 4 years ago

I wrote most of the Visonic code in DomotiGa, but i only could test it with a PowerMaster30 via the RS232 interface. Can you enable the debugging and email me the debug output to me? If it is a problem with decoding of the protocol, then I will fix it asap (and ofcourse thanks for testing ;-)).

BTW: You tried to connect it to the remote programmer? Just to see IF communication is possible (never tried the USB kit).

RE: Visonic PowerMaster 10 - Added by Alexie almost 4 years ago

BTW2: my email is ualex73 [at] gmail [dot] com

RE: Visonic PowerMaster 10 - Added by kingofnuls over 3 years ago

Hello Alex,

Because of (thanks to) you, i've connected my french Powermaster 30 to a Domotiga3 Rpi B (Tx,Rx GPIO directly on PM30 PC Connector).

I'm learning to use Domotiga which is more difficult than domoticz (imho). But your work is fantastic and i can now send my magnetic contacts informations and my alarm status to my domoticz controller. Domotiga will also be in charge of SMS communication.

For your information, in order to have the connection up with my PM30, i had to put the right download code ($iDownloadCode) in file Sources/CVisonic in gambas IDE.

Have you in project to switch on and off the alarm panel in Domotiga? Is this presently possible ?

THanks again for your hard work.

Best regards,


RE: Visonic PowerMaster 10 - Added by Alexie over 3 years ago


You shouldn't have to change the download code, when i was testing with my panel (which a different download code) - the visonic panel should tell the code is wrong and DomotiGa will re-enroll the panel with the new download code.

It isn't possible to arm/disarm YET, it is on my todo list. The code is almost there, but i still need to test and make the function for it.

RE: Visonic PowerMaster 10 - Added by kingofnuls over 3 years ago

i know about the download code, but not working for me if i didn't do that with Domotiga ver 1.21. I was desperate (a little :) ) and tried to understand why Domotiga didn't can see my visonic. My PM30 has firmware v17 or v16 ; i can't tell it for sure. Perhaps a reason...

Thanks for your answers.

RE: Visonic PowerMaster 10 - Added by janssuuh about 3 years ago

Hi All,

Again a new bee to Domotiga!
I'm using an Visonic Powermaster + for a while now and like to connect this to my Raspberry PI.
I do have the RS232 RJ45 board, but! It's connected to the cell-phone unit...

My question is whether anyone has any experience in multiply'ing this RS232 port. I allready orderd some diodes, to setup a Master (Visonic) / Slave (Raspberry and Cell module) network.

I've read some articles which say it is needed to use 'pull up' resistors. This is the part I don't really understand...

With kind regards Jeroen

RE: Visonic PowerMaster 10 - Added by Alexie about 3 years ago

I am not sure you can multiplex RS232, because the RS232 is used for communication in both directions.

If it helps, i can add a 'relay' functionality it the Visonic plugin, then it will relay the sensor/status functionality to another TCP/IP based application (but you can't send anything, because that confuses things).

RE: Visonic PowerMaster 10 - Added by janssuuh about 3 years ago

Hi Alexie,

Thanks for your reply!

It really would be great to (just) read/listen the Powermax status/messages.
In this case I probably only need to connect the Powermax TX (Cell module RX) to Raspbery TX pin.

Cable / diode delivery should be tonight. Maybe I'd still try to connect Master/Slave, like described here;

Is there any difference in connecting to RJ45 RS232 port, or just directly to Powermax pins?
I'm asking this because I have a spare Powermax (first edition), which has no 232 module.
I'd like to test on my 'old' hardware.

I documented how I asume the pin connection are to be made. I'll upload this tonight.

RE: Visonic PowerMaster 10 - Added by janssuuh about 3 years ago

Hi Alex,

Diodes arrived. However it seems like Visonic created their own 'multiply' solution by adding an 'aux' port to the cell-phone unit.

I think my best shot is to connect Raspberry to that port:

RE: Visonic PowerMaster 10 - Added by janssuuh about 3 years ago

Hi Alex,

Yesterday I did the wiring and connections, pinout:

GSM Module (Powermax) RJ45:
[3] TX
[5] gnd
[6] RX

[6] gnd
[8] TX
[10] RX

Today started testing Domotiga.
After disabling ttyAMA0 shell in Raspi-Config I managed to have Domotiga Serial Monitor say;

I just can't get it to provide any output!
Is this window supposed to send 'input' to 'output' part? Writing content from 'input' and pressing 'Enter' does'nt do anything. (I triggered some PIR's aswell)

I copied this small python script to monitor any serial communication:

When writing and reading are both active (changed write script port to '/dev/ttyAMA0') still no activity at all!

Am I doing something terribly wrong? I think I am not even far enough to test whether Cell-module is doing the right thing :S

Kind regards

RE: Visonic PowerMaster 10 - Added by janssuuh about 3 years ago

Ok, so latest state;

I tried to shorten RX / TX pin on my Raspberry.
The Read / Write code now gives me data, so Raspberry seems to 'work'.

I've read on the Internet that with custom hardware connecting to the Powermax + you'll be 'emulatiing' an PowerLink device. Therefor I tried to add this in my Powermax menu (uninstalled / cell-phone module for now btw).

While trying to add this Powerlink, the Powermax telss me 'even geduld aub'. At this point the Read script gives some kind of data (strange signs) and shortly after that the Powermax tells me with a long beep that the connection has'nt been established.

Any suggestions?
Thanks in advance

Kind regards Jeroen

log.PNG (155 KB) log.PNG

RE: Visonic PowerMaster 10 - Added by kingofnuls about 3 years ago


Are you sure about the serial speed ? Because it looks like a bad speed setting, or perhaps your cables are too long...

By the way, If you have a powerMAX (not MASTER), look at this link. It is very intersting imho.

RE: Visonic PowerMaster 10 - Added by Davide about 2 years ago


I'm looking to buy a Powermaster 10, but I don't know how I'm supposed to physically connect it to an Rpi running DomotiGa.

A question to Edevag: did you manage to have it working using the USB program kit cable? Or with something else?