Project

General

Profile

Using the gambas repo maintained by domotiga: error

Added by Martin over 1 year ago

When installning gambas with the repo this error occur

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gambas3 : Depends: gambas3-gb-gsl (>= 3.9.2+jessie1) but it is not going to be installed
Depends: gambas3-gb-gtk-opengl (>= 3.9.2+jessie1) but it is not going to be installed
Depends: gambas3-gb-mysql (>= 3.9.2+jessie1) but it is not going to be installed
Depends: gambas3-gb-opengl-glsl (>= 3.9.2+jessie1) but it is not going to be installed
Depends: gambas3-gb-opengl-glu (>= 3.9.2+jessie1) but it is not going to be installed
Depends: gambas3-gb-qt4-opengl (>= 3.9.2+jessie1) but it is not going to be installed
Depends: gambas3-gb-opengl-sge (>= 3.9.2+jessie1) but it is not going to be installed
Depends: gambas3-gb-openssl (>= 3.9.2+jessie1) but it is not going to be installed
Depends: gambas3-gb-pdf (>= 3.9.2+jessie1) but it is not going to be installed
Depends: gambas3-gb-sdl (>= 3.9.2+jessie1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Using RPI3 latest raspbian


Replies (8)

RE: Using the gambas repo maintained by domotiga: error - Added by Martin over 1 year ago

I did realize raspbian has moved on from Jessie been to long since i messed around with RPI
soo any chance for stretch packets soon ?

RE: Using the gambas repo maintained by domotiga: error - Added by Alexie over 1 year ago

I compiled the Stretch packages now and email them to Ron, hopefully he will publish them soon. I didn't know either they moved to Stretch/Debian 9 ;-)

RE: Using the gambas repo maintained by domotiga: error - Added by rdnzl over 1 year ago

I uploaded them to the repo, please test.
See here for small instruction:
https://domotiga.nl/apt/README.txt

RE: Using the gambas repo maintained by domotiga: error - Added by Martin over 1 year ago

In stretch they rmoved libjson0 libjson0-dev (for openzwave comp) and so far i cannot find any easy replacement packages

RE: Using the gambas repo maintained by domotiga: error - Added by Martin over 1 year ago

You have to do this in stretch
cd /usr/lib/arm-linux-gnueabihf/
sudo ln -s libjson-c.a libjson.a
then it will complie

RE: Using the gambas repo maintained by domotiga: error - Added by Alexie over 1 year ago

Ok, will have a look into that libjson0 (maybe for now, libjson-c is enough to do it?) ... I personally want to remove that library, because it has some weird side-effects in the domozwave lib.

RE: Using the gambas repo maintained by domotiga: error - Added by Martin over 1 year ago

I would say thats a good idea Alexie, when installing domotiga on centos/fedora ( and now debian9 )its always the libjson that makes a mess.

    (1-8/8)