Project

General

Profile

Bug #37

Plugwise old firmware not working after upgrade to latest SVN(r403)

Added by Anonymous over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Database
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
fixed

Description

After upgrading to the last version of Domotiga plugwise has stopped working and with debug enabled produces these messages in debug.log:
2010/09/03 22:07:41 [Plugwise] Checking power usage of device 'Wasmachine' with address 000D6F00003FF0D1
2010/09/03 22:07:41 [Plugwise] Calibration Request
2010/09/03 22:07:41 [Plugwise] MAC: 000D6F00003FF0D1
2010/09/03 22:07:41 [Plugwise] String: 0026000D6F00003FF0D1 CRC: 1F87
2010/09/03 22:07:41 [Plugwise] Write: 0026000D6F00003FF0D11F87
2010/09/03 22:07:41 [Plugwise] GetPowerInfo() didn't get expected answer for address '000D6F00003FF0D1' result was _
2010/09/03 22:07:41 [Plugwise] Is module plugged in and address correct?
2010/09/03 22:07:41 [Plugwise] Checking relay state of device 'Wasmachine' with address 000D6F00003FF0D1
2010/09/03 22:07:41 [Plugwise] MAC: 000D6F00003FF0D1
2010/09/03 22:07:41 [Plugwise] String: 0023000D6F00003FF0D1 CRC: 4CED
2010/09/03 22:07:41 [Plugwise] Write: 0023000D6F00003FF0D14CED
2010/09/03 22:07:41 [Plugwise] GetDeviceInfo() didn't get expected answer.
2010/09/03 22:07:41 [Plugwise] Is module plugged in and address correct?

The plugs are on their original firmware(2008) and are switchable en readable with the 'Source'-software.
Checking if the right firmware is selected has reveiled that it is and switching it to 2009 produces the same:
2010/09/03 22:42:18 [Plugwise] Checking power usage of device 'Wasmachine' with address 000D6F00003FF0D1
2010/09/03 22:42:18 [Plugwise] Calibration Request
2010/09/03 22:42:18 [Plugwise] MAC: 000D6F00003FF0D1
2010/09/03 22:42:18 [Plugwise] String: 0026000D6F00003FF0D1 CRC: 1F87
2010/09/03 22:42:18 [Plugwise] Write: 0026000D6F00003FF0D11F87
2010/09/03 22:42:18 [Plugwise] GetPowerInfo() didn't get expected answer for address '000D6F00003FF0D1' result was _
2010/09/03 22:42:18 [Plugwise] Is module plugged in and address correct?
2010/09/03 22:42:18 [Plugwise] Checking relay state of device 'Wasmachine' with address 000D6F00003FF0D1
2010/09/03 22:42:18 [Plugwise] MAC: 000D6F00003FF0D1
2010/09/03 22:42:18 [Plugwise] String: 0023000D6F00003FF0D1 CRC: 4CED
2010/09/03 22:42:18 [Plugwise] Write: 0023000D6F00003FF0D14CED
2010/09/03 22:42:18 [Plugwise] GetDeviceInfo() didn't get expected answer.
2010/09/03 22:42:18 [Plugwise] Is module plugged in and address correct?

Do both firmwares work the same in this respect? Would it help(and still work) to upgrade the firmware of the plugs to the latest release?

History

#1 Updated by rdnzl over 8 years ago

  • Status changed from New to In Progress

It could be just a bug, don't upgrade the plugs yet, they could be handy for resolving this ,I will check the code, and report back.

#2 Updated by rdnzl over 8 years ago

Jos, could you check if revision r405 fixes your problems?
I cannot test it because my plugs are on the new firmware.

#3 Updated by Anonymous over 8 years ago

Replying to [comment:2 rdnzl]:

Jos, could you check if revision r405 fixes your problems?
I cannot test it because my plugs are on the new firmware.

Seems to have the same result, I quit Gambas, did a svn up and then start gambas and run from the IDE.

#4 Updated by rdnzl over 8 years ago

You run DomotiGa from your svn repos directory?
I have changed a minor thing in r407, please try that, but I noticed that your logs has no result after, " result was "... this should display at least part of a response.

Are you sure the old version still works and all your Plugwise serial port/firmware and plug address settings are still correct?

As you don't seem to get anything back from the plugs...

Communication basics hasn't changed, just the length of the string and the format of it...

#5 Updated by Anonymous over 8 years ago

I've checked out a fresh copy from svn opened it as a new project in Gambas and unset and set the portsetting of plugwise, one of these things seems to have helped and now the plugs report back and I can switch as well. I don't know what the cause exactly was, but it seems to have been solved somehow... :s

#6 Updated by rdnzl over 8 years ago

  • Status changed from In Progress to Closed
  • Resolution set to fixed

Also available in: Atom PDF