Project

General

Profile

Bug #371

Impossible to start new version 1.0.012

Added by smortier over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
11/20/2013
Due date:
% Done:

100%

Estimated time:
Resolution:
Fixed

Description

Hello,

I've just updated DomotiGa to the lastest version, as usual.
But now, it's impossible to run the server. I don't know where is the problem.

Here the server-main logs :

2013/11/20 13:05:59 [Main] Checking directory structure ...
2013/11/20 13:05:59 [Main] Connecting to database ...
2013/11/20 13:05:59 [Main] Loading modules ...
2013/11/20 13:05:59 [Main] Starting setup ...
2013/11/20 13:05:59 [Main] ERROR: Result is not available 1 while loading settings at Main.GetSettings.847!
Is your database version correct?
2013/11/20 13:05:59 Stopping running timers.
2013/11/20 13:05:59 [Main] ---
Program End ---

Thank you,
Seb.

History

#1 Updated by jessekerkhoven over 5 years ago

  • Status changed from New to In Progress

Hi,

Did you upgrade your database to version 1.0.012? You can check by execute following sql statement: "SELECT * FROM version ORDER BY db DESC LIMIT 1".

#2 Updated by smortier over 5 years ago

Yes !
I have
ID DB
57 1.0.012

I think that the problem comes from zwave.
Table domotiga.settings_openzwave has been renamed and now, is empty..

#3 Updated by jessekerkhoven over 5 years ago

Hi,

That is strange.
You can create and fill it with:

DROP TABLE IF EXISTS `settings_openzwave`;
/*!40101 SET saved_cs_client = @character_set_client /;
/
!40101 SET character_set_client = utf8 /;
CREATE TABLE `settings_openzwave` (
`id` int(11) NOT NULL,
`enabled` tinyint(1) DEFAULT NULL,
`serialport` varchar(128) DEFAULT NULL,
`baudrate` varchar(32) DEFAULT NULL,
`reloadnodes` tinyint(1) DEFAULT NULL,
`polltime` int(11) DEFAULT NULL,
`debug` tinyint(1) DEFAULT NULL,
`polltimesleeping` varchar(16) DEFAULT NULL,
`enablepollsleeping` tinyint(1) DEFAULT NULL,
`enablepolllistening` tinyint(1) DEFAULT NULL,
`polltimelistening` varchar(16) DEFAULT NULL,
`updateneighbor` varchar(16) DEFAULT NULL,
`enableupdateneighbor` tinyint(1) DEFAULT NULL,
PRIMARY KEY (`id`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1;
/
!40101 SET character_set_client = @saved_cs_client */;

--
-- Dumping data for table `settings_openzwave`
--

LOCK TABLES `settings_openzwave` WRITE;
/*!40000 ALTER TABLE `settings_openzwave` DISABLE KEYS /;
INSERT INTO `settings_openzwave` VALUES (0,0,'/dev/ttyUSB3','115200',0,0,0,'
/30 * * * ',0,0,'/30 * * * ','30 23 * * *',0),(1,0,'/dev/ttyUSB3','115200',0,0,0,'/30 * * * ',0,0,'/30 * * * ','30 23 * * *',0);
/
!40000 ALTER TABLE `settings_openzwave` ENABLE KEYS */;
UNLOCK TABLES;

I hope it didn't mess up something else. Sorry for the problems.

#4 Updated by smortier over 5 years ago

Okay,

I've just run this sql query :

INSERT INTO `settings_openzwave` (`id`, `enabled`, `serialport`, `baudrate`, `reloadnodes`, `polltime`, `debug`, `polltimesleeping`, `enablepollsleeping`, `enablepolllistening`, `polltimelistening`, `updateneighbor`, `enableupdateneighbor`) VALUES
(0, 0, '/dev/ttyUSB4', '115200', 0, 0, 0, '*/30 * * * ', 0, NULL, NULL, '30 23 * * *', 0),
(1, 0, '/dev/ttyUSB3', '115200', 0, 0, 1, '
/30 * * * *', 0, NULL, NULL, '30 23 * * *', 0)

And now everything is OK

I think that the problem is that I started to upgrade to 1.0.012 yesterday, just before the final release. So, I've performed 10011to10012.sql twice (yesterday and today).

Probably there are a mess with table settings_zwave rename to settings_openzwave.

Now it's ok ! thank you for your help.
This issue could be closed.

#5 Updated by jessekerkhoven over 5 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100
  • Resolution set to Fixed

Ok, that is the reason it dont work. The interim upgrade files are used by the developers. When we are ready for a new version of DomotiGa, DomotiGa calls automatically for a upgrade.

Also available in: Atom PDF