Project

General

Profile

Bug #497

Oregon THGR328N not working

Added by raymonvdm almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
DomotiGaServer3
Target version:
Start date:
11/16/2014
Due date:
% Done:

100%

Estimated time:
Resolution:
Fixed

Description

Hi Ron,

I just send u an email but a ticket would be a better idea :)

The sensor is not picking up the temperature en the humidity is not showing %

2014/11/16 18:58:16 50CA2C134F212000453F55 TH420225 THGR328 CH 1 counter:12 addr:4F temp:20.2°C | 68.36°F hum:50 Comfort Battery OK2014/11/16 18:58:17 [RFXComRX] ERROR: Parsing Oregon data packet: CA2C134F212000453F55FFFF955926000000000000000000000000000000 Type mismatch: wanted Integer, got String instead at CRFXComRX.ProcessOregon.1800

History

#1 Updated by Alexie almost 5 years ago

Is it the device you bought in Germany? :
http://www.domoticaforum.eu/viewtopic.php?f=15&t=10014

Just curious, maybe it is a special one ...

#2 Updated by raymonvdm almost 5 years ago

It is one bought in Germany.

#3 Updated by rdnzl almost 5 years ago

Can you check what you receive for data when interface is connected to RFXmngr tool? (on windows)
If I inject the packet from your log 50CA2C134F212000453F55 into it, it reports '1st byte doesn't correspond with data packet lenght!'

So packet is invalid, could be that DomotiGa or interface is not receiving it correctly, or that sensor sends invalid/not support packet...

#4 Updated by rdnzl almost 5 years ago

Ignore message above I was using old tool.. ;) I will fix the parse issue soon.

#5 Updated by Alexie almost 5 years ago

  • Status changed from New to Feedback
  • Assignee set to rdnzl
  • Target version changed from 1.0.018 to 1.0.019
  • % Done changed from 0 to 100
  • Resolution set to Fixed

I believe Ron fixed it now in the BETA branch ;)

#6 Updated by Alexie almost 5 years ago

1.0.019 is released now.

#7 Updated by wwolkers almost 5 years ago

  • Status changed from Feedback to Closed

I can confirm this is resolved now, 3 sensors working fine for me.

Also available in: Atom PDF