Project

General

Profile

Bug #516

[Shell] Error when trying to run '/home/andy/scripts/scene1.sh' : System error #24: Too many open files. gb.net.curl: warning: unable to create the client watching pipe: Too many open files

Added by mommeke over 4 years ago. Updated about 3 years ago.

Status:
In Progress
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/15/2014
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

I have the following problem under Domotiga version 1.0.019 and gambas Version: 3.6.2-50.29~ubuntu12.04.1

I use 14 "shell" devices that link to a simple bash script on the same server.
These scripts are for:
-triggering scenes (I could not get https://www.domotiga.nl/boards/2/topics/2267?r=4815 to work, and somehow any actions I define are just executed every hour, regardless of the trigger configuration. So I made scripts that do something if they receive the "On" parameter, and else (like when domotiga polls them) just echo their name)
-controlling my squeezebox volume (I was unable to figure out how to use the squeezebox plugin for my logitechmediaserver with squeezeslave)
-read values (e.g. calculated energy costs based on youless output, "now playing" values from xbmc/dreambox/squeezebox)
the interval for shell devices is set to 30 seconds (one of the scripts returns the squeezebox nowplaying coverart link, which I then show on a smartvisu page, so that should not be minutes behind to keep it in sync with the song playing)

When I start domotigaserver, all seems to work fine. But I noticed that some time after starting domotigaserver, the logs are filled with:
[Shell] Error when trying to run '/home/andy/scripts/scene1.sh' : System error #24: Too many open files.
(note: similar lines are shown for all my shellscripts)
gb.net.curl: warning: unable to create the client watching pipe: Too many open files

From that moment on, requests no longer seem to be executed.

I also noticed in "top", gbr3 shows as using 100% cpu:
1129 andy 20 0 45064 10m 3824 R 100 0.3 630:43.59 gbr3

History

#1 Updated by mommeke over 4 years ago

maybe this information is also interesting:
lsof|grep pipe|grep gbr3|wc -l
1002

lsof shows over 1000 of lines like this:
gbr3 1129 andy 1019r FIFO 0,8 0t0 30898511 pipe
gbr3 1129 andy 1020w FIFO 0,8 0t0 30899322 pipe
gbr3 1129 andy 1021r FIFO 0,8 0t0 30896685 pipe
gbr3 1129 andy 1022w FIFO 0,8 0t0 30898511 pipe
gbr3 1129 andy 1023w FIFO 0,8 0t0 30896685 pipe

#2 Updated by rdnzl over 4 years ago

It's a bug in gambas 3.6.2, please try gambas trunk version.

#3 Updated by mommeke over 4 years ago

Thanks, that actually seems to have solved it. The number of open pipes seems to remain stable while it was always increasing in the official gamba version.
I had seen the high prio bugreport but didn't think my issue was related.

#4 Updated by rdnzl over 4 years ago

  • Status changed from New to Closed

#5 Updated by rdnzl over 4 years ago

  • Status changed from Closed to In Progress

#7 Updated by mommeke over 4 years ago

doublecheck before confirming:
disabled all shell devices but one (picked the party script with stderr redirections)
test with lsof | grep gbr3 | wc -l
when domotiga is not running: 0
immediately after domotiga startup: 292
after 30 minutes: 296
after one hour: 306
I think this can count as confirmation. I did not throw a party during these measurements ;-)
This number of pipes is not yet affecting operations, but it keeps on increasing. Once there are about 1200 of them, domotiga logs errors about it. The more similar scripts (shell devices) are enabled in domotiga, the faster it reaches that 'limit'.

#8 Updated by rdnzl over 4 years ago

So given a default Shell plugin poll timer of 300 sec (5 Mins) you get about one file descriptor per script call.
Will check, we also add a debugging option to Gambas for file descriptors, so we can see whats happening..

#9 Updated by mommeke over 4 years ago

I have the 'run interval' set to 15 seconds.
One of the scripts is for the artist, title and coverart of what is playing through squeezebox. If it would be 5 minutes behind, it would show the details of the previous song.
If I set it to 1 second (just for testing), the number of open pipes increases faster.

#10 Updated by mommeke about 4 years ago

were you able to reproduce this?
I'm currently on gambas 3.7.90+svn7109+build53~ubuntu12.04.1 and it's still happening.
PS you can close #568

#11 Updated by mommeke about 4 years ago

meanwhile running gambas 3.7.90+svn7144+build53~ubuntu12.04.1
issue still occurs...

#12 Updated by jessekerkhoven about 4 years ago

I will have a look.
I will try to reproduce it.

#13 Updated by jessekerkhoven about 4 years ago

I tested it for more than 1 hour, but cannot reproduce it.

Are you sure that there are no leftovers of gambas 3.6.2?
And can you reproduce it with a minimalistic script?

#14 Updated by mommeke about 4 years ago

I updated gambas as per the wiki article https://www.domotiga.nl/projects/domotiga/wiki/DomotiGa_Upgrade#Gambas so first deleting gambas and then reinstalling. So I would assume this gives a clean installation without leftovers - do you have a suggestion how to verify this?
andy@homeserver:~$ gambas3 -V
3.7.90

Over the past months I ran domotiga with only a few scripts while waiting for an update on this issue here. (Decreasing the number of active shellscripts extends the time domotiga can be used before crashing. So that way I didn't have to kill domotiga every day anymore, but had to miss a lot of useful things because they were disabled.)
These scripts are pretty simple and only do something useful if you call them with "On" after it.

When running DomotigaServer it now returns details about the output of my scripts, so I enabled some more scripts again.
Run Interval is set to 300 seconds in the shell interface properties.
Here's the output from starting domotiga till the first line of the 2nd execution interval:

andy@homeserver:~/domotiga$ ./DomotiGaServer3.gambas
2015/07/06 12:18:43 [Main] ---- Program Restart ----
2015/07/06 12:18:43 [Main] Starting DomotiGaServer3 V1.0.021 last updated on 2015-07-06 12:18:29
2015/07/06 12:18:43 [Main] Running on host 'homeserver' (pid 24652) as user 'andy'. (id 1000)
2015/07/06 12:18:43 [Main] Detected IP Addresses '192.168.1.7, 172.16.0.1, 172.16.2.1, 172.16.4.1, 172.16.6.1, 172.16.8.1, 172.16.10.1, 172.16.12.1, 172.16.14.1'.
2015/07/06 12:18:43 [Main] Detected Broadcast Addresses '192.168.1.255, 172.16.1.255, 172.16.3.255, 172.16.5.255, 172.16.7.255, 172.16.9.255, 172.16.11.255, 172.16.13.255, 172.16.15.255'.
2015/07/06 12:18:43 [Main] System language is 'en_US.UTF-8' on architecture 'x86'.
2015/07/06 12:18:43 [Main] Program base directory is '/home/andy/domotiga'.
2015/07/06 12:18:43 [Main] Database settings are loaded from 'server-domotiga.conf'.
2015/07/06 12:18:43 [Main] Active logfiles are 'server-main-2015-07.log', 'server-speak-2015-07.log' and 'server-debug-2015-07.log'.
2015/07/06 12:18:43 [Main] Running on Gambas version 3.7.90
2015/07/06 12:18:43 [Main] Server uptime is 12:18:43 up 16:20, 3 users, load average: 5.36, 4.98, 5.26
2015/07/06 12:18:43 [Main] Checking directory structure ...
2015/07/06 12:18:43 [Main] Connecting to database ...
2015/07/06 12:18:43 [MySQL] Database on host 'localhost'.
2015/07/06 12:18:43 [MySQL] Port used 3306.
2015/07/06 12:18:43 [MySQL] Version is '50543'.
2015/07/06 12:18:43 [Main] Loading modules ...
2015/07/06 12:18:43 [Main] Starting setup ...
2015/07/06 12:18:43 [Main] Globalvars Restored.
2015/07/06 12:18:43 [Plugin] Broadcast UDP enabled.
2015/07/06 12:18:43 [BroadcastUDP] Broadcast UDP Server ready, broadcasting to Port 19009
2015/07/06 12:18:43 [Plugin] e-mail client disabled.
2015/07/06 12:18:43 [Plugin] Sound support disabled.
2015/07/06 12:18:43 [Plugin] VoiceText support disabled.
2015/07/06 12:18:43 [Plugin] Thermostat support disabled.
2015/07/06 12:18:43 [Plugin] RRDTool support enabled.
2015/07/06 12:18:43 [Plugin] Server Statistics disabled.
2015/07/06 12:18:43 [Plugin] xPL support disabled.
2015/07/06 12:18:43 [Plugin] RFXCom xPL support disabled.
2015/07/06 12:18:43 [Plugin] XBMC xPL support disabled.
2015/07/06 12:18:43 [Plugin] JSON-RPC enabled.
2015/07/06 12:18:43 [JSONRPC] JSON-RPC Server listening on Port 9091
2015/07/06 12:18:43 [Plugin] Mochad X10 enabled.
2015/07/06 12:18:43 [Mochad] Mochad X10 TCP interface connecting to 192.168.1.7:1099
2015/07/06 12:18:43 [Plugin] NetworkDetect enabled.
2015/07/06 12:18:43 [NetworkDetect] Found arp-scan executable.
2015/07/06 12:18:43 [Plugin] RFXCom Transceiver enabled.
2015/07/06 12:18:43 [RFXComTRX] RFXCom Transceiver serial interface connected to port /dev/serial/by-id/usb-RFXCOM_RFXtrx433_A1XQFHZQ-if00-port0
2015/07/06 12:18:43 [RFXComTRX] Relay listening for client on port 10011
2015/07/06 12:18:43 [Plugin] Shell enabled.
2015/07/06 12:18:43 [Plugin] SmartVISU Server enabled.
2015/07/06 12:18:43 [SmartVISU] SmartVISU Server listening on Port 2121
2015/07/06 12:18:43 [Plugin] Squeeze Server enabled.
2015/07/06 12:18:43 [SqueezeServer] Squeeze Server TCP interface connecting to localhost:9090
2015/07/06 12:18:43 [Plugin] WeatherUnderground enabled.
2015/07/06 12:18:43 [Plugin] YouLess enabled.
2015/07/06 12:18:43 [Main] Done with setup ...
2015/07/06 12:18:43 [Main] Starting main program ...
2015/07/06 12:18:43 [Main] House mode is set to 'Normal'.
2015/07/06 12:18:43 [Main] Mute mode is set to 'Audio Enabled'.
2015/07/06 12:18:43 [Main] Entering main program loop ...
2015/07/06 12:18:43 [Astro] Latitude: 51.087349, Longitude: 3.448371, Timezone: CEST
2015/07/06 12:18:43 [Astro] Sunrise at 05:38, Sunset at 22:02
2015/07/06 12:18:43 [Astro] Twilight Sunrise at 04:52, Twilight Sunset at 22:48 civil
2015/07/06 12:18:43 [Astro] Moon phase is Waning gibbous.
2015/07/06 12:18:43 [Astro] Moon is in Aquarius.
2015/07/06 12:18:43 [Astro] Age from new 19 days.
2015/07/06 12:18:43 [Astro] Distance 57.76 Earth radii.
2015/07/06 12:18:43 [Astro] Ecliptic latitude: 1.99 degrees.
2015/07/06 12:18:43 [Astro] Ecliptic longitude: 342.37 degrees.
2015/07/06 12:18:43 [Astro] Season is summer.
2015/07/06 12:18:43 [Main] The Time of Day is afternoon.
2015/07/06 12:18:43 [Main] It's light outside.
2015/07/06 12:18:43 [Main] DomotiGa is running for 0 days, 0 hrs, 0 mins, and 0 secs.
2015/07/06 12:18:43 [Main] Main Debug enabled.
2015/07/06 12:18:43 [Main] The current tagline is 'Unable to locate Coffee -- Operator Halted!'
2015/07/06 12:18:43 [Mochad] TCP interface connected.
2015/07/06 12:18:43 [SqueezeServer] TCP interface connected.
2015/07/06 12:18:43 [SqueezeServer] Is running version 7.7.5.
2015/07/06 12:18:43 [SqueezeServer] Current player list:
2015/07/06 12:18:43 [SqueezeServer] ID: 90:e6:ba:8b:1a:8d Name: veranda Status: Online
2015/07/06 12:18:43 [SqueezeServer] Your SqueezeServer database holds 3895 albums and 41861 songs from 1033 artists.
2015/07/06 12:23:43 [Shell] Getting value(s) for device 'scene4' with command '/home/andy/scripts/scene4.sh'.
2015/07/06 12:23:43 [Shell] Getting value(s) for device 'youlesshistoriek' with command '/bin/bash /home/andy/scripts/energie/historiek.sh'.
2015/07/06 12:23:43 [Shell] Getting value(s) for device 'babykamer.snapshot' with command '/home/andy/scripts/snapshotbaby.sh'.
2015/07/06 12:23:43 [Shell] Getting value(s) for device 'LMS' with command '/home/andy/scripts/sqbxnow.sh'.
2015/07/06 12:23:43 [Shell] Getting value(s) for device 'squeezeslave' with command '/bin/bash /home/andy/scripts/radio.sh'.
2015/07/06 12:23:43 [Shell] Getting value(s) for device 'deurbel' with command '/bin/cat /home/andy/scripts/deurbeldate'.
2015/07/06 12:23:43 [Shell] Getting value(s) for device 'xbmc.salon' with command '/home/andy/scripts/xbmc.salon.nowplaying.sh'.
2015/07/06 12:23:43 [Shell] Getting value(s) for device 'xbmc.slk' with command '/home/andy/scripts/xbmc.slk.nowplaying.sh'.
2015/07/06 12:23:43 [Shell] Getting value(s) for device 'sqbxvolu' with command '/home/andy/scripts/sqbxvolu.sh'.
2015/07/06 12:23:43 [Shell] Getting value(s) for device 'sqbxvold' with command '/home/andy/scripts/sqbxvold.sh'.
2015/07/06 12:23:43 [Shell] Getting value(s) for device 'youlesskostvandaag' with command '/home/andy/scripts/energie/sofar.sh'.
2015/07/06 12:23:43 [Shell] Getting value(s) for device 'luisterbaby' with command '/bin/bash /home/andy/scripts/luisterbaby.sh'.
2015/07/06 12:23:43 [Shell] Getting value(s) for device 'garage.poort' with command '/home/andy/scripts/garage.sh'.
2015/07/06 12:23:43 [Shell] Getting value(s) for device 'calcelec' with command '/bin/bash /home/andy/scripts/energie/berekenelecverbruik.sh'.
2015/07/06 12:23:43 [Shell] < '/home/andy/scripts/garage.sh\n'
2015/07/06 12:23:43 [Shell] Device with id '174' returned value1 = '/home/andy/scripts/garage.sh'
2015/07/06 12:23:43 [Shell] < '/home/andy/scripts/luisterbaby.sh\n'
2015/07/06 12:23:43 [Shell] Device with id '158' returned value1 = '/home/andy/scripts/luisterbaby.sh'
2015/07/06 12:23:43 [Shell] < 'volume\n'
2015/07/06 12:23:43 [Shell] Device with id '115' returned value1 = 'volume'
2015/07/06 12:23:43 [Shell] < '/home/andy/scripts/sqbxvolu.sh\n'
2015/07/06 12:23:43 [Shell] Device with id '114' returned value1 = '/home/andy/scripts/sqbxvolu.sh'
2015/07/06 12:23:43 [Shell] < 'uit\n0\n'
2015/07/06 12:23:43 [Shell] Device with id '75' returned value1 = 'uit', value2 = '0'
2015/07/06 12:23:43 [Shell] < '04/07/2015 15:36:16\n'
2015/07/06 12:23:43 [Shell] Device with id '77' returned value1 = '04/07/2015 15:36:16'
2015/07/06 12:23:43 [Shell] < 'De Collega's\n1\n'
2015/07/06 12:23:43 [Shell] Device with id '72' returned value1 = 'De Collega's', value2 = '1'
2015/07/06 12:23:43 [Shell] < '/home/andy/scripts/snapshotbaby.sh \n'
2015/07/06 12:23:43 [Shell] Device with id '159' returned value1 = '/home/andy/scripts/snapshotbaby.sh '
2015/07/06 12:23:43 [Shell] < '/home/andy/scripts/scene4.sh \n'
2015/07/06 12:23:43 [Shell] Device with id '142' returned value1 = '/home/andy/scripts/scene4.sh '
2015/07/06 12:23:43 [Shell] < 'On\nDe Collega's\n'
2015/07/06 12:23:43 [Shell] Device with id '71' returned value1 = 'On', value2 = 'De Collega's'
2015/07/06 12:23:43 [Shell] < '1.38\n6.90\n'
2015/07/06 12:23:43 [Shell] Device with id '118' returned value1 = '1.38', value2 = '6.90'
2015/07/06 12:23:43 [Shell] < '3.00\n15.0\n724.\n3623\n'
2015/07/06 12:23:43 [Shell] Device with id '149' returned value1 = '3.00', value2 = '15.0', value3 = '724.', value4 = '3623'
2015/07/06 12:23:43 [Shell] < '4568.720\n1.38\n724\n6.90\n3623\n3.8\n19\n'
2015/07/06 12:23:43 [Shell] Device with id '177' returned value1 = '4568.720', value2 = '1.38', value3 = '724', value4 = '6.90', value5 = '3623', value6 = '3.8', value7 = '19'
2015/07/06 12:25:50 [Shell] < 'uit\n0\n\n1\n'
2015/07/06 12:25:50 [Shell] Device with id '74' returned value1 = 'uit', value2 = '0', value3 = '', value4 = '1'
2015/07/06 12:28:43 [Shell] Getting value(s) for device 'scene4' with command '/home/andy/scripts/scene4.sh'.
...

I noticed something that may be the key to this issue:
You see in the output above that almost every line of shell log output came at 12h23. Two minutes later there are 2 more lines printed. (and another 3 minutes later the next round begins)

Right after domotiga starts (in this case at 12h18), there are 103 open pipes (counted with lsof | grep gbr3 | wc -l)
At 12h23 (when the first execution interval has been printed) it is 105
At 12h25 (when the last 2 lines from the first execution interval were finally printed) it drops back to 103.

So it looks like the last shell device, with id 74, somehow takes longer to return its values, causing a temporary higher number of open pipes.
I have 12 more shell devices still disabled, some of them may or may not also show this behaviour. In combination with a shorter 'Run Interval' than the current 300 seconds (I used to have it set to 30 seconds to keep NowPlaying values usable), this could very well cause the ever increasing number of open pipes imho...

shell device 74 links to a script that queries some raspberry pi's running kodi (aka xbmc) and a dreambox to print what is currently playing.
Now the dreambox is no longer in use here, so that part was timing out. I have now commented it out so it only queries active boxes.
Will now leave it running like this and see if it remains stable.

#15 Updated by mommeke about 4 years ago

domotiga was last started at 13h16. Meanwhile, at 14h53, the number of open pipes has increased from 103 to 114.
So there 's still something wrong. Are there any options in gambas or domotiga I could enable to help investigating? In post 8 Ron mentioned a debugging option for file descriptors in Gambas?

#16 Updated by jessekerkhoven about 4 years ago

I remembered that upgrading from 3.6 to 3.7 that is also needed to run dist-upgrade but it don't think it is a upgrade problem.

As you mentioned long script could be one of the options, maybe you can check if all script dont take to long?

Also lsof shows open files but open files is in this case IPv4, IPv6, unix, regular file, etc, maybe it is a combined problem with networking and shell scripts?

Maybe you can give 2 times the output of lsof | grep gbr3 one after DomotiGa started and is nicely settled and one after a long periode where the open pipes where increased.

In the main time, hopefully Ron has an vision on this problem? And trying a single hello world shell device and checking of the problem also occurs?

#17 Updated by mommeke about 4 years ago

I searched for dist-upgrade on this site but the results seem all relevant for raspberry pi, which I'm not using here. This is on a x86 machine with ubuntu 12.04 LTS
All other scripts return their result very quick, there was just that one script that tried to ssh to an unreachable ip, I eliminated that already.
here is the output of lsof|grep gbr3 after domotiga startup:

gbr3 29282 andy cwd DIR 8,1 4096 1203685 /home/andy/domotiga
gbr3 29282 andy rtd DIR 8,1 4096 2 /
gbr3 29282 andy txt REG 8,1 389488 403443 /usr/bin/gbx3
gbr3 29282 andy mem REG 8,1 47040 131317 /lib/i386-linux-gnu/libnss_files-2.15.so
gbr3 29282 andy mem REG 8,1 42652 131302 /lib/i386-linux-gnu/libnss_nis-2.15.so
gbr3 29282 andy mem REG 8,1 92016 156634 /lib/i386-linux-gnu/libnsl-2.15.so
gbr3 29282 andy mem REG 8,1 1496200 396661 /usr/lib/i386-linux-gnu/libstdc++.so.6.0.21
gbr3 29282 andy mem REG 8,1 22080 178681 /lib/i386-linux-gnu/libnss_dns-2.15.so
gbr3 29282 andy mem REG 8,1 30520 178677 /lib/i386-linux-gnu/libnss_compat-2.15.so
gbr3 29282 andy mem REG 8,1 51866 402315 /usr/lib/gambas3/gb.xml.rpc.gambas
gbr3 29282 andy mem REG 8,1 238984 131977 /lib/i386-linux-gnu/libpcre.so.3.12.1
gbr3 29282 andy mem REG 8,1 9632 131127 /lib/libnss_mdns4_minimal.so.2
gbr3 29282 andy mem REG 8,1 8708 403133 /usr/lib/gambas3/gb.util.web.gambas
gbr3 29282 andy mem REG 8,1 79836 402300 /usr/lib/gambas3/gb.xml.so.0.0.0
gbr3 29282 andy mem REG 8,1 672692 398502 /usr/lib/i386-linux-gnu/libsqlite3.so.0.8.6
gbr3 29282 andy mem REG 8,1 284152 398555 /usr/lib/i386-linux-gnu/libhx509.so.5.0.0
gbr3 29282 andy mem REG 8,1 55540 398299 /usr/lib/i386-linux-gnu/libheimbase.so.1.0.0
gbr3 29282 andy mem REG 8,1 165328 398301 /usr/lib/i386-linux-gnu/libwind.so.0.0.0
gbr3 29282 andy mem REG 8,1 13672 131935 /lib/i386-linux-gnu/libkeyutils.so.1.4
gbr3 29282 andy mem REG 8,1 13668 131931 /lib/i386-linux-gnu/libgpg-error.so.0.8.0
gbr3 29282 andy mem REG 8,1 67472 398401 /usr/lib/i386-linux-gnu/libp11-kit.so.0.0.0
gbr3 29282 andy mem REG 8,1 67060 397605 /usr/lib/i386-linux-gnu/libtasn1.so.3.1.12
gbr3 29282 andy mem REG 8,1 84444 401589 /usr/lib/i386-linux-gnu/libroken.so.18.1.0
gbr3 29282 andy mem REG 8,1 211524 398025 /usr/lib/i386-linux-gnu/libhcrypto.so.4.1.0
gbr3 29282 andy mem REG 8,1 670348 398463 /usr/lib/i386-linux-gnu/libasn1.so.8.0.0
gbr3 29282 andy mem REG 8,1 532268 398307 /usr/lib/i386-linux-gnu/libkrb5.so.26.0.0
gbr3 29282 andy mem REG 8,1 26492 398332 /usr/lib/i386-linux-gnu/libheimntlm.so.0.1.0
gbr3 29282 andy mem REG 8,1 30320 395129 /usr/lib/i386-linux-gnu/libkrb5support.so.0.1
gbr3 29282 andy mem REG 8,1 157284 394573 /usr/lib/i386-linux-gnu/libk5crypto.so.3.1
gbr3 29282 andy mem REG 8,1 842684 395126 /usr/lib/i386-linux-gnu/libkrb5.so.3.3
gbr3 29282 andy mem REG 8,1 545196 131074 /lib/i386-linux-gnu/libgcrypt.so.11.7.0
gbr3 29282 andy mem REG 8,1 801644 396669 /usr/lib/i386-linux-gnu/libgnutls.so.26.21.8
gbr3 29282 andy mem REG 8,1 243280 398303 /usr/lib/i386-linux-gnu/libgssapi.so.3.0.0
gbr3 29282 andy mem REG 8,1 108348 398479 /usr/lib/i386-linux-gnu/libsasl2.so.2.0.25
gbr3 29282 andy mem REG 8,1 83776 131911 /lib/i386-linux-gnu/libresolv-2.15.so
gbr3 29282 andy mem REG 8,1 104348 398472 /usr/lib/i386-linux-gnu/librtmp.so.0
gbr3 29282 andy mem REG 8,1 1738900 208724 /lib/i386-linux-gnu/libcrypto.so.1.0.0
gbr3 29282 andy mem REG 8,1 354468 208725 /lib/i386-linux-gnu/libssl.so.1.0.0
gbr3 29282 andy mem REG 8,1 249660 395123 /usr/lib/i386-linux-gnu/libgssapi_krb5.so.2.2
gbr3 29282 andy mem REG 8,1 325872 405145 /usr/lib/i386-linux-gnu/libldap_r-2.4.so.2.8.1
gbr3 29282 andy mem REG 8,1 54696 405146 /usr/lib/i386-linux-gnu/liblber-2.4.so.2.8.1
gbr3 29282 andy mem REG 8,1 206412 398312 /usr/lib/i386-linux-gnu/libidn.so.11.6.6
gbr3 29282 andy mem REG 8,1 379568 394504 /usr/lib/i386-linux-gnu/libcurl.so.4.2.0
gbr3 29282 andy mem REG 8,1 11660 402298 /usr/lib/gambas3/gb.xml.gambas
gbr3 29282 andy mem REG 8,1 42745 402292 /usr/lib/gambas3/gb.web.gambas
gbr3 29282 andy mem REG 8,1 10516 402252 /usr/lib/gambas3/gb.signal.so.0.0.0
gbr3 29282 andy mem REG 8,1 14828 402207 /usr/lib/gambas3/gb.pcre.so.0.0.0
gbr3 29282 andy mem REG 8,1 29879 402124 /usr/lib/gambas3/gb.net.smtp.gambas
gbr3 29282 andy mem REG 8,1 116236 131113 /lib/i386-linux-gnu/libgcc_s.so.1
gbr3 29282 andy mem REG 8,1 83572 132015 /lib/i386-linux-gnu/libz.so.1.2.3.4
gbr3 29282 andy mem REG 8,1 3228884 394855 /usr/lib/i386-linux-gnu/libmysqlclient.so.18.0.0
gbr3 29282 andy mem REG 8,1 13864 131322 /lib/i386-linux-gnu/libcom_err.so.2.1
gbr3 29282 andy mem REG 8,1 38096 400729 /usr/lib/gambas3/gb.net.curl.so.0.0.0
gbr3 29282 andy mem REG 8,1 54708 400676 /usr/lib/gambas3/gb.net.so.0.0.0
gbr3 29282 andy mem REG 8,1 34316 178675 /lib/i386-linux-gnu/libcrypt-2.15.so
gbr3 29282 andy mem REG 8,1 4132 400709 /usr/lib/gambas3/gb.net.curl.gambas
gbr3 29282 andy mem REG 8,1 16424 403104 /usr/lib/gambas3/gb.settings.gambas
gbr3 29282 andy mem REG 8,1 30480 400791 /usr/lib/gambas3/gb.db.mysql.so.0.0.0
gbr3 29282 andy mem REG 8,1 55800 398581 /usr/lib/gambas3/gb.db.so.0.0.0
gbr3 29282 andy mem REG 8,1 8748544 400694 /usr/lib/locale/locale-archive
gbr3 29282 andy mem REG 8,1 1870986 1183066 /home/andy/domotiga/DomotiGaServer3.gambas
gbr3 29282 andy mem REG 8,1 30684 131319 /lib/i386-linux-gnu/librt-2.15.so
gbr3 29282 andy mem REG 8,1 21944 398162 /usr/lib/i386-linux-gnu/libffi.so.6.0.0
gbr3 29282 andy mem REG 8,1 13940 178676 /lib/i386-linux-gnu/libdl-2.15.so
gbr3 29282 andy mem REG 8,1 173576 156637 /lib/i386-linux-gnu/libm-2.15.so
gbr3 29282 andy mem REG 8,1 124663 131310 /lib/i386-linux-gnu/libpthread-2.15.so
gbr3 29282 andy mem REG 8,1 1730024 178678 /lib/i386-linux-gnu/libc-2.15.so
gbr3 29282 andy mem REG 8,1 14754 398619 /usr/lib/gambas3/gb.db.gambas
gbr3 29282 andy mem REG 8,1 3665 398723 /usr/lib/gambas3/gb.data.gambas
gbr3 29282 andy mem REG 8,1 61588 398727 /usr/lib/gambas3/gb.data.so.0.0.0
gbr3 29282 andy mem REG 8,1 9776 398717 /usr/lib/gambas3/gb.crypt.so.0.0.0
gbr3 29282 andy mem REG 8,1 10000 398713 /usr/lib/gambas3/gb.compress.so.0.0.0
gbr3 29282 andy mem REG 8,1 59300 807889 /opt/lib/libmediaclient.so
gbr3 29282 andy mem REG 8,1 134344 131321 /lib/i386-linux-gnu/ld-2.15.so
gbr3 29282 andy 0u CHR 136,1 0t0 4 /dev/pts/1
gbr3 29282 andy 1u CHR 136,1 0t0 4 /dev/pts/1
gbr3 29282 andy 2u CHR 136,1 0t0 4 /dev/pts/1
gbr3 29282 andy 3r REG 8,1 1870986 1183066 /home/andy/domotiga/DomotiGaServer3.gambas
gbr3 29282 andy 4r REG 8,1 3665 398723 /usr/lib/gambas3/gb.data.gambas
gbr3 29282 andy 5r REG 8,1 14754 398619 /usr/lib/gambas3/gb.db.gambas
gbr3 29282 andy 6r REG 8,1 16424 403104 /usr/lib/gambas3/gb.settings.gambas
gbr3 29282 andy 7r FIFO 0,8 0t0 25342507 pipe
gbr3 29282 andy 8w FIFO 0,8 0t0 25342507 pipe
gbr3 29282 andy 9r REG 8,1 4132 400709 /usr/lib/gambas3/gb.net.curl.gambas
gbr3 29282 andy 10r REG 8,1 29879 402124 /usr/lib/gambas3/gb.net.smtp.gambas
gbr3 29282 andy 11r REG 8,1 42745 402292 /usr/lib/gambas3/gb.web.gambas
gbr3 29282 andy 12r REG 8,1 11660 402298 /usr/lib/gambas3/gb.xml.gambas
gbr3 29282 andy 13r REG 8,1 51866 402315 /usr/lib/gambas3/gb.xml.rpc.gambas
gbr3 29282 andy 14r REG 8,1 8708 403133 /usr/lib/gambas3/gb.util.web.gambas
gbr3 29282 andy 15u REG 8,1 97873 2491598 /home/andy/domotiga/logs/server-main-2015-07.log
gbr3 29282 andy 16u REG 8,1 0 2491599 /home/andy/domotiga/logs/server-speak-2015-07.log
gbr3 29282 andy 17u REG 8,1 8043233 2491600 /home/andy/domotiga/logs/server-debug-2015-07.log
gbr3 29282 andy 18u unix 0x00000000 0t0 25345044 socket
gbr3 29282 andy 19u IPv4 25345046 0t0 UDP *:54758
gbr3 29282 andy 20u IPv4 25345079 0t0 TCP *:9091 (LISTEN)
gbr3 29282 andy 21u IPv4 25345080 0t0 TCP homeserver:41996->homeserver:rmiregistry (ESTABLISHED)
gbr3 29282 andy 22u CHR 188,0 0t0 12505 /dev/ttyUSB0
gbr3 29282 andy 23u IPv4 25344054 0t0 TCP *:10011 (LISTEN)
gbr3 29282 andy 24u IPv4 25344055 0t0 TCP *:iprop (LISTEN)
gbr3 29282 andy 25u IPv4 25344056 0t0 TCP localhost:53040->localhost:9090 (ESTABLISHED)
gbr3 29282 andy 26r FIFO 0,8 0t0 25345110 pipe
gbr3 29282 andy 29w FIFO 0,8 0t0 25345110 pipe
gbr3 29282 andy 30u IPv4 25341741 0t0 TCP homeserver:56056->a184-50-168-120.deploy.static.akamaitechnologies.com:http (ESTABLISHED)

and after +- 11 hours:

gbr3 29282 andy cwd DIR 8,1 4096 1203685 /home/andy/domotiga
gbr3 29282 andy rtd DIR 8,1 4096 2 /
gbr3 29282 andy txt REG 8,1 389488 403443 /usr/bin/gbx3
gbr3 29282 andy mem REG 8,1 47040 131317 /lib/i386-linux-gnu/libnss_files-2.15.so
gbr3 29282 andy mem REG 8,1 42652 131302 /lib/i386-linux-gnu/libnss_nis-2.15.so
gbr3 29282 andy mem REG 8,1 92016 156634 /lib/i386-linux-gnu/libnsl-2.15.so
gbr3 29282 andy mem REG 8,1 1496200 396661 /usr/lib/i386-linux-gnu/libstdc++.so.6.0.21
gbr3 29282 andy mem REG 8,1 22080 178681 /lib/i386-linux-gnu/libnss_dns-2.15.so
gbr3 29282 andy mem REG 8,1 30520 178677 /lib/i386-linux-gnu/libnss_compat-2.15.so
gbr3 29282 andy mem REG 8,1 51866 402315 /usr/lib/gambas3/gb.xml.rpc.gambas
gbr3 29282 andy mem REG 8,1 238984 131977 /lib/i386-linux-gnu/libpcre.so.3.12.1
gbr3 29282 andy mem REG 8,1 9632 131127 /lib/libnss_mdns4_minimal.so.2
gbr3 29282 andy mem REG 8,1 8708 403133 /usr/lib/gambas3/gb.util.web.gambas
gbr3 29282 andy mem REG 8,1 79836 402300 /usr/lib/gambas3/gb.xml.so.0.0.0
gbr3 29282 andy mem REG 8,1 672692 398502 /usr/lib/i386-linux-gnu/libsqlite3.so.0.8.6
gbr3 29282 andy mem REG 8,1 284152 398555 /usr/lib/i386-linux-gnu/libhx509.so.5.0.0
gbr3 29282 andy mem REG 8,1 55540 398299 /usr/lib/i386-linux-gnu/libheimbase.so.1.0.0
gbr3 29282 andy mem REG 8,1 165328 398301 /usr/lib/i386-linux-gnu/libwind.so.0.0.0
gbr3 29282 andy mem REG 8,1 13672 131935 /lib/i386-linux-gnu/libkeyutils.so.1.4
gbr3 29282 andy mem REG 8,1 13668 131931 /lib/i386-linux-gnu/libgpg-error.so.0.8.0
gbr3 29282 andy mem REG 8,1 67472 398401 /usr/lib/i386-linux-gnu/libp11-kit.so.0.0.0
gbr3 29282 andy mem REG 8,1 67060 397605 /usr/lib/i386-linux-gnu/libtasn1.so.3.1.12
gbr3 29282 andy mem REG 8,1 84444 401589 /usr/lib/i386-linux-gnu/libroken.so.18.1.0
gbr3 29282 andy mem REG 8,1 211524 398025 /usr/lib/i386-linux-gnu/libhcrypto.so.4.1.0
gbr3 29282 andy mem REG 8,1 670348 398463 /usr/lib/i386-linux-gnu/libasn1.so.8.0.0
gbr3 29282 andy mem REG 8,1 532268 398307 /usr/lib/i386-linux-gnu/libkrb5.so.26.0.0
gbr3 29282 andy mem REG 8,1 26492 398332 /usr/lib/i386-linux-gnu/libheimntlm.so.0.1.0
gbr3 29282 andy mem REG 8,1 30320 395129 /usr/lib/i386-linux-gnu/libkrb5support.so.0.1
gbr3 29282 andy mem REG 8,1 157284 394573 /usr/lib/i386-linux-gnu/libk5crypto.so.3.1
gbr3 29282 andy mem REG 8,1 842684 395126 /usr/lib/i386-linux-gnu/libkrb5.so.3.3
gbr3 29282 andy mem REG 8,1 545196 131074 /lib/i386-linux-gnu/libgcrypt.so.11.7.0
gbr3 29282 andy mem REG 8,1 801644 396669 /usr/lib/i386-linux-gnu/libgnutls.so.26.21.8
gbr3 29282 andy mem REG 8,1 243280 398303 /usr/lib/i386-linux-gnu/libgssapi.so.3.0.0
gbr3 29282 andy mem REG 8,1 108348 398479 /usr/lib/i386-linux-gnu/libsasl2.so.2.0.25
gbr3 29282 andy mem REG 8,1 83776 131911 /lib/i386-linux-gnu/libresolv-2.15.so
gbr3 29282 andy mem REG 8,1 104348 398472 /usr/lib/i386-linux-gnu/librtmp.so.0
gbr3 29282 andy mem REG 8,1 1738900 208724 /lib/i386-linux-gnu/libcrypto.so.1.0.0
gbr3 29282 andy mem REG 8,1 354468 208725 /lib/i386-linux-gnu/libssl.so.1.0.0
gbr3 29282 andy mem REG 8,1 249660 395123 /usr/lib/i386-linux-gnu/libgssapi_krb5.so.2.2
gbr3 29282 andy mem REG 8,1 325872 405145 /usr/lib/i386-linux-gnu/libldap_r-2.4.so.2.8.1
gbr3 29282 andy mem REG 8,1 54696 405146 /usr/lib/i386-linux-gnu/liblber-2.4.so.2.8.1
gbr3 29282 andy mem REG 8,1 206412 398312 /usr/lib/i386-linux-gnu/libidn.so.11.6.6
gbr3 29282 andy mem REG 8,1 379568 394504 /usr/lib/i386-linux-gnu/libcurl.so.4.2.0
gbr3 29282 andy mem REG 8,1 11660 402298 /usr/lib/gambas3/gb.xml.gambas
gbr3 29282 andy mem REG 8,1 42745 402292 /usr/lib/gambas3/gb.web.gambas
gbr3 29282 andy mem REG 8,1 10516 402252 /usr/lib/gambas3/gb.signal.so.0.0.0
gbr3 29282 andy mem REG 8,1 14828 402207 /usr/lib/gambas3/gb.pcre.so.0.0.0
gbr3 29282 andy mem REG 8,1 29879 402124 /usr/lib/gambas3/gb.net.smtp.gambas
gbr3 29282 andy mem REG 8,1 116236 131113 /lib/i386-linux-gnu/libgcc_s.so.1
gbr3 29282 andy mem REG 8,1 83572 132015 /lib/i386-linux-gnu/libz.so.1.2.3.4
gbr3 29282 andy mem REG 8,1 3228884 394855 /usr/lib/i386-linux-gnu/libmysqlclient.so.18.0.0
gbr3 29282 andy mem REG 8,1 13864 131322 /lib/i386-linux-gnu/libcom_err.so.2.1
gbr3 29282 andy mem REG 8,1 38096 400729 /usr/lib/gambas3/gb.net.curl.so.0.0.0
gbr3 29282 andy mem REG 8,1 54708 400676 /usr/lib/gambas3/gb.net.so.0.0.0
gbr3 29282 andy mem REG 8,1 34316 178675 /lib/i386-linux-gnu/libcrypt-2.15.so
gbr3 29282 andy mem REG 8,1 4132 400709 /usr/lib/gambas3/gb.net.curl.gambas
gbr3 29282 andy mem REG 8,1 16424 403104 /usr/lib/gambas3/gb.settings.gambas
gbr3 29282 andy mem REG 8,1 30480 400791 /usr/lib/gambas3/gb.db.mysql.so.0.0.0
gbr3 29282 andy mem REG 8,1 55800 398581 /usr/lib/gambas3/gb.db.so.0.0.0
gbr3 29282 andy mem REG 8,1 8748544 400694 /usr/lib/locale/locale-archive
gbr3 29282 andy mem REG 8,1 1870986 1183066 /home/andy/domotiga/DomotiGaServer3.gambas
gbr3 29282 andy mem REG 8,1 30684 131319 /lib/i386-linux-gnu/librt-2.15.so
gbr3 29282 andy mem REG 8,1 21944 398162 /usr/lib/i386-linux-gnu/libffi.so.6.0.0
gbr3 29282 andy mem REG 8,1 13940 178676 /lib/i386-linux-gnu/libdl-2.15.so
gbr3 29282 andy mem REG 8,1 173576 156637 /lib/i386-linux-gnu/libm-2.15.so
gbr3 29282 andy mem REG 8,1 124663 131310 /lib/i386-linux-gnu/libpthread-2.15.so
gbr3 29282 andy mem REG 8,1 1730024 178678 /lib/i386-linux-gnu/libc-2.15.so
gbr3 29282 andy mem REG 8,1 14754 398619 /usr/lib/gambas3/gb.db.gambas
gbr3 29282 andy mem REG 8,1 3665 398723 /usr/lib/gambas3/gb.data.gambas
gbr3 29282 andy mem REG 8,1 61588 398727 /usr/lib/gambas3/gb.data.so.0.0.0
gbr3 29282 andy mem REG 8,1 9776 398717 /usr/lib/gambas3/gb.crypt.so.0.0.0
gbr3 29282 andy mem REG 8,1 10000 398713 /usr/lib/gambas3/gb.compress.so.0.0.0
gbr3 29282 andy mem REG 8,1 59300 807889 /opt/lib/libmediaclient.so
gbr3 29282 andy mem REG 8,1 134344 131321 /lib/i386-linux-gnu/ld-2.15.so
gbr3 29282 andy 0u CHR 136,1 0t0 4 /dev/pts/1
gbr3 29282 andy 1u CHR 136,1 0t0 4 /dev/pts/1
gbr3 29282 andy 2u CHR 136,1 0t0 4 /dev/pts/1
gbr3 29282 andy 3r REG 8,1 1870986 1183066 /home/andy/domotiga/DomotiGaServer3.gambas
gbr3 29282 andy 4r REG 8,1 3665 398723 /usr/lib/gambas3/gb.data.gambas
gbr3 29282 andy 5r REG 8,1 14754 398619 /usr/lib/gambas3/gb.db.gambas
gbr3 29282 andy 6r REG 8,1 16424 403104 /usr/lib/gambas3/gb.settings.gambas
gbr3 29282 andy 7r FIFO 0,8 0t0 25342507 pipe
gbr3 29282 andy 8w FIFO 0,8 0t0 25342507 pipe
gbr3 29282 andy 9r REG 8,1 4132 400709 /usr/lib/gambas3/gb.net.curl.gambas
gbr3 29282 andy 10r REG 8,1 29879 402124 /usr/lib/gambas3/gb.net.smtp.gambas
gbr3 29282 andy 11r REG 8,1 42745 402292 /usr/lib/gambas3/gb.web.gambas
gbr3 29282 andy 12r REG 8,1 11660 402298 /usr/lib/gambas3/gb.xml.gambas
gbr3 29282 andy 13r REG 8,1 51866 402315 /usr/lib/gambas3/gb.xml.rpc.gambas
gbr3 29282 andy 14r REG 8,1 8708 403133 /usr/lib/gambas3/gb.util.web.gambas
gbr3 29282 andy 15u REG 8,1 100562 2491598 /home/andy/domotiga/logs/server-main-2015-07.log
gbr3 29282 andy 16u REG 8,1 0 2491599 /home/andy/domotiga/logs/server-speak-2015-07.log
gbr3 29282 andy 17u REG 8,1 8610634 2491600 /home/andy/domotiga/logs/server-debug-2015-07.log
gbr3 29282 andy 18u unix 0x00000000 0t0 25345044 socket
gbr3 29282 andy 19u IPv4 25345046 0t0 UDP *:54758
gbr3 29282 andy 20u IPv4 25345079 0t0 TCP *:9091 (LISTEN)
gbr3 29282 andy 21u IPv4 25345080 0t0 TCP homeserver:41996->homeserver:rmiregistry (ESTABLISHED)
gbr3 29282 andy 22u CHR 188,0 0t0 12505 /dev/ttyUSB0
gbr3 29282 andy 23u IPv4 25344054 0t0 TCP *:10011 (LISTEN)
gbr3 29282 andy 24u IPv4 25344055 0t0 TCP *:iprop (LISTEN)
gbr3 29282 andy 25u IPv4 25344056 0t0 TCP localhost:53040->localhost:9090 (ESTABLISHED)
gbr3 29282 andy 26r FIFO 0,8 0t0 25345110 pipe
gbr3 29282 andy 27r FIFO 0,8 0t0 25799336 pipe
gbr3 29282 andy 28u IPv4 25432874 0t0 TCP homeserver:iprop->medion-pc:57816 (ESTABLISHED)
gbr3 29282 andy 29w FIFO 0,8 0t0 25345110 pipe
gbr3 29282 andy 30r FIFO 0,8 0t0 25867683 pipe
gbr3 29282 andy 31r FIFO 0,8 0t0 26465003 pipe
gbr3 29282 andy 32r FIFO 0,8 0t0 25699316 pipe
gbr3 29282 andy 33r FIFO 0,8 0t0 25722054 pipe
gbr3 29282 andy 34r FIFO 0,8 0t0 26194561 pipe
gbr3 29282 andy 35r FIFO 0,8 0t0 26346888 pipe
gbr3 29282 andy 36r FIFO 0,8 0t0 26018639 pipe
gbr3 29282 andy 37r FIFO 0,8 0t0 26194565 pipe
gbr3 29282 andy 38r FIFO 0,8 0t0 26358917 pipe
gbr3 29282 andy 39r FIFO 0,8 0t0 25711455 pipe
gbr3 29282 andy 40r FIFO 0,8 0t0 26279947 pipe
gbr3 29282 andy 41r FIFO 0,8 0t0 26610112 pipe
gbr3 29282 andy 42r FIFO 0,8 0t0 26620153 pipe
gbr3 29282 andy 43r FIFO 0,8 0t0 25431937 pipe
gbr3 29282 andy 44r FIFO 0,8 0t0 25379039 pipe
gbr3 29282 andy 45r FIFO 0,8 0t0 25998818 pipe
gbr3 29282 andy 46r FIFO 0,8 0t0 25423097 pipe
gbr3 29282 andy 47r FIFO 0,8 0t0 25475626 pipe
gbr3 29282 andy 48r FIFO 0,8 0t0 25642753 pipe
gbr3 29282 andy 49r FIFO 0,8 0t0 25476341 pipe
gbr3 29282 andy 50r FIFO 0,8 0t0 25712663 pipe
gbr3 29282 andy 51r FIFO 0,8 0t0 25554303 pipe
gbr3 29282 andy 52r FIFO 0,8 0t0 26400483 pipe
gbr3 29282 andy 53r FIFO 0,8 0t0 25392340 pipe
gbr3 29282 andy 54r FIFO 0,8 0t0 26608593 pipe
gbr3 29282 andy 55r FIFO 0,8 0t0 26421244 pipe
gbr3 29282 andy 56r FIFO 0,8 0t0 25867702 pipe
gbr3 29282 andy 57r FIFO 0,8 0t0 25562055 pipe
gbr3 29282 andy 58r FIFO 0,8 0t0 25619370 pipe
gbr3 29282 andy 59r FIFO 0,8 0t0 25562059 pipe
gbr3 29282 andy 60r FIFO 0,8 0t0 26547287 pipe
gbr3 29282 andy 61r FIFO 0,8 0t0 26504236 pipe
gbr3 29282 andy 62r FIFO 0,8 0t0 26666705 pipe
gbr3 29282 andy 63r FIFO 0,8 0t0 26657567 pipe
gbr3 29282 andy 64r FIFO 0,8 0t0 26700904 pipe
gbr3 29282 andy 65r FIFO 0,8 0t0 26868609 pipe
gbr3 29282 andy 66r FIFO 0,8 0t0 26727878 pipe
gbr3 29282 andy 67r FIFO 0,8 0t0 26861653 pipe
gbr3 29282 andy 68r FIFO 0,8 0t0 26245587 pipe
gbr3 29282 andy 69r FIFO 0,8 0t0 26891276 pipe
gbr3 29282 andy 70r FIFO 0,8 0t0 25956532 pipe
gbr3 29282 andy 71r FIFO 0,8 0t0 26796217 pipe
gbr3 29282 andy 72r FIFO 0,8 0t0 27034663 pipe
gbr3 29282 andy 73r FIFO 0,8 0t0 26669681 pipe
gbr3 29282 andy 74r FIFO 0,8 0t0 26933172 pipe
gbr3 29282 andy 75r FIFO 0,8 0t0 27012771 pipe
gbr3 29282 andy 77r FIFO 0,8 0t0 26025897 pipe
gbr3 29282 andy 78r FIFO 0,8 0t0 26965485 pipe
gbr3 29282 andy 79r FIFO 0,8 0t0 27033613 pipe
gbr3 29282 andy 82r FIFO 0,8 0t0 27042058 pipe
gbr3 29282 andy 83r FIFO 0,8 0t0 26546119 pipe
gbr3 29282 andy 85r FIFO 0,8 0t0 27033622 pipe
gbr3 29282 andy 90r FIFO 0,8 0t0 26589261 pipe
gbr3 29282 andy 93r FIFO 0,8 0t0 26678099 pipe
gbr3 29282 andy 94r FIFO 0,8 0t0 26691002 pipe
gbr3 29282 andy 95r FIFO 0,8 0t0 26900382 pipe
gbr3 29282 andy 98r FIFO 0,8 0t0 26975808 pipe
gbr3 29282 andy 103r FIFO 0,8 0t0 26956252 pipe
gbr3 29282 andy 105r FIFO 0,8 0t0 27000198 pipe

I'll try the hello world test.

#18 Updated by jessekerkhoven about 4 years ago

Your test logs showed that it is indeed the special pipes called FIFO that are not closed or finished correctly. See for more info http://www.gnu.org/software/libc/manual/html_node/FIFO-Special-Files.html

Looking forward to the hello world test, if it is a general problem or that you have a script that causes strange behaviour that gambas doesn't understand.

#19 Updated by mommeke almost 4 years ago

I believe I found what caused this.
One of the shell devices reads a text file that contains a date (last time the doorbell rang). That value is then shown on a smartvisu page.
The date string contains some slashes by default, for instance: "2015/09/26 10:48:12".
By adding a sed command to replace those slashes with dashes, this device could not increase the number of open gbr3 pipes anymore.
So then I edited all my other scripts that could potentially output a slash, and re-enabled them all. The number of open gbr3 fifo pipes on the server always stays 4 now.

#20 Updated by Alexie almost 4 years ago

mommeke:

Can you give examples (e.g. content of the scripts) what gave problems, and how you resolved it? Maybe we can fix it somewhere.

#21 Updated by Alexie almost 4 years ago

Should read more :-)

Can you confirm you have an issue IF the script outputs "2015/09/09 11:01" instead of "2015-09-09 11:01"?

Are you running on x86, x86_64, Cubie or Pi(2)?

#22 Updated by mommeke almost 4 years ago

correct, when a shellscript output contains slashes, new fifo pipes get created.
This is on an x86 (a regular pc running a 32 bit ubuntu kernel)

#23 Updated by mommeke about 3 years ago

installed domotiga on an intel nuc with ubuntu wily. Did not restore database but instead started from a blank domotiga install.
Setup zwave, rfxcom, smartvisu, json-rpc, shell.
Configured about 15 shell devices, and still experiencing increasing number of gbr3 FIFO pipes.
moved most of the script files to a subfolder so domotiga couldn't find them anymore.

Only a few scripts left for testing:
one that does nothing more than cat a text file (shows timestamp when doorbell was last used)
one that counts the number of open pipes for gbr3 (lsof|grep pipe|grep gbr3|wc -l), enabled logging so I can see a nice graph in smartvisu.
and one that only echoes "OK" if you don't add On as a $1 parameter (so when domotiga runs it to update the value, it just calls the shell script without parameters and so it just gets "OK". If I trigger it from a switch which adds On as a parameter then it runs several actions, but I didn't even do that while testing)

Each time I add a script (place it back from the subfolder to where domotiga can find and use it again), I see the pipes graph go up. (even without actually using a switch to trigger the scripts, so just by the regular polling interval in domotiga)
3 active shell devices and 75 to 95 pipes at this moment. Is that a possibly normal amount?
Is there some ratio between one shell device and how many additional pipes that should open?
Does the time it takes to run a shellscript relates to the number of pipes it creates?
Is there some timeout involved so that scripts that take several seconds to complete can cause too many pipes that don't get closed?
Are there some characters that should not be in the values returned by the scripts? Or some maximum length of a value that when it is exceeded, can cause more pipes to be used?
can I add something in my scripts to force the pipes to close after execution or prevent unnecessary pipes?
Is there some extra verbose logging that could help understanding which script causes which pipes and what is in them?

Also available in: Atom PDF