Project

General

Profile

Bug #584

rfxcom commander - chime: fat client domotiga crashes. type issue

Added by johanvandyck over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
DomotiGa3 Client
Target version:
Start date:
09/04/2015
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed

Description

Hi

While using RFXCom commander, chime tab, the fat client DomotiGa3.gambas is crashing with:

FToolsRFXComCmdr.Command_Chime.1406: #6: Type mismatch: wanted Float, got String instead
FToolsRFXComCmdr.Command_Chime.1406 FToolsRFXComCmdr.btnChimeBigBen_Click.1416

I try to send a "push chime button" command via rfxcom commander. My chime is on ID 00B8 and of type ByronSX.
- open rfxcom commander, select chime tab
- select unit code. This is not easy as the list is empty and only 1 char is visible out of the 2. (see screenshot rfcc-chime)
- push a sound button like 'big ben'
--> domotiga client crashes, error is given in the putty command line. (see 2 lines above)

I use:
- Cubian with latest software
- Domotiga 1.021

RFCC-chime.jpg (29.6 KB) RFCC-chime.jpg rfxcom commander - chime not good readable johanvandyck, 09/04/2015 04:51 PM
2392

History

#1 Updated by Alexie over 3 years ago

  • Status changed from New to Resolved
  • Assignee set to Alexie
  • Target version changed from 1.0.021 to 1.0.022
  • Resolution set to Fixed

The bug is fixed in the BETA branch, thanks for catching it. If you want to fix it temporary easiest to do it is then:

Edit ~/domotiga/DomotiGa3/.src/Tools/FToolsRFXComCmdr.class, and replace line 1406:
cData["address"] = Format(cmbChimeUnit.Text, "00")
With:
cData["address"] = cmbChimeUnit.Text

#2 Updated by Alexie over 3 years ago

And then run also compile :-)

cd ~/domotiga
tools/compile.sh

#3 Updated by johanvandyck over 3 years ago

Hi

It is partially solved for me: ok, the function is working. After selecting the hex-value and push a "song-button", my chime is working. However the drop down list is still "filled with hidden values". See screenshot in my bug report.

thanks for the quick help.

Johan.

#4 Updated by Alexie over 3 years ago

Which desktop/distro/gui/theme/etc are you using? I can't reproduce the "filled with hidden values" on my Ubuntu 14.04LTS.

#5 Updated by johanvandyck over 3 years ago

Hi

My hardware is cubie II. I'm using Cubian (http://cubian.org/) which is based on Debian. With all updates installed, I'm running Cubian/Debian 7.8.
I'm running Gambas 3.7.1
I'm running Domotiga 1.0.21 (sources of may 17th compiled myself)

I think it is a more general problem of the tfxcom commander. Also other selection fiels like of the fan-tab or radiator 1 have the same issue.

Kind regards

Johan.

#6 Updated by wwolkers over 3 years ago

  • Status changed from Resolved to Closed

Fixed in 1.0.022

Also available in: Atom PDF