Project

General

Profile

Bug #596

Domotiga Server stops at 60% of startup

Added by salmr over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
DomotiGaServer3
Target version:
Start date:
01/10/2016
Due date:
% Done:

0%

Estimated time:
Resolution:
Works For Me

Description

I am using a Raspberry Pi 2 as a server for running the program.

I had some errors at the startup of Domotiga so I decided to check all debug boxes to track any issues. After is action the startup of Domotiga is halted at 60% (loading plugins)

how do I get this running again?

History

#1 Updated by rdnzl over 3 years ago

  • Status changed from New to In Progress

I could be caused by having selected the wrong interface port (usb/serial) for a specific device?
If so, try to unplug them before starting DomotiGa, then check settings of enabled plugins (if any)

#2 Updated by salmr over 3 years ago

I have installed a Razberry and I was using the open zwave commander for the devices. It has been working for 6 months without any problems. Unfortunate, I can only access the raspberry via remote desktop or web browser because I am not home for some time.

I start the program from the command line. I cannot enter the program via the computer because it stalls at 60%. Are there any files I can delete that would make it work again?

#3 Updated by johanvandyck over 3 years ago

Hi

I use cubieboard2 (dual core 1Ghz cpu), 1Gb ram.

I noticed ticking the checkbox "debug device" let DomotiGa stall for about a minute on 60% to "initiate" plugins. If the checkbox is off, startup is finished in the blink of an eye. If an client was already running and I (re)start my server, I see - word by word - every plugin passing in the main log... Are you sure if you wait long enough, the client doesn't come up?

I think I also need to mention this:
- if debug devices is on,
- if I open the debug tab to view my debug log and let the tab open
then
my client becomes nearly onresponsive after let's say 10 minutes till an hour. I can't see a lack or resources (nodes, ram, cpu, disk). But clearly the debug option is heavy for a small board. (On my vmware client in ubunto, no such thing is seen).

I suggest to only check the needed debug options. And of course, you might be interested in a backup strategy. Personally, when I messed up things, I restore a backup of yesterday. https://www.domotiga.nl/boards/1/topics/6101?r=6566#message-6566
I've no server at hand, but can check tonight how to disable debug options by command line in the database.

Regards

Johan

#4 Updated by johanvandyck over 3 years ago

Hi

the query to set my main settings to default.

INSERT INTO `domotiga`.`settings_main` (
`id` ,
`sleeptime` ,
`flushtime` ,
`debug` ,
`logbuffer` ,
`authentication` ,
`startpage` ,
`debugevents` ,
`debugdevices` ,
`debugenergy` ,
`debugplugin` ,
`debugglobalvar` ,
`hometoppanel` ,
`homeleftpanel` ,
`homerightpanel` ,
`homebottompanel` ,
`autodevicecreate` ,
`logallvalueupdates` ,
`logprefix`
)
VALUES (
'0', '250', '10000', '0', '15000', '0', 'FLogfiles', '0', '0', '0', '0', '0', 'TagLine|Power Usage', 'House Mode', 'Outside', 'Main log', '1', '0', NULL
);

succes

Johan.

#5 Updated by salmr over 3 years ago

I had a lot of problems with the running DomotiGa installation. Luckily I had a backup image of my 6.0.20 installation. I used it and upgraded to 6.0.22 and it was working stable. Also the Zwave USB adapter seems to respond much faster.

Thanks for the reply anyway.

Rob

#6 Updated by Alexie over 3 years ago

  • Status changed from In Progress to Closed
  • Resolution set to Works For Me

Closing the issue, because it is resolved.

Also available in: Atom PDF